Oil pressure sender failure

Discuss Electrical problems here.

Moderator: Moderators

mobylette
Minor Fan
Posts: 132
Joined: Sat Feb 13, 2010 5:02 pm
MMOC Member: Yes

Oil pressure sender failure

Postby mobylette » Sat May 04, 2019 11:46 am

Just been out for a run in my Morris with recently rebuilt engine. Stopped for lunch and on restarting the oil pressure light was glowing brightly :( . I had fitted an oil pressure gauge, and was relieved to see it showing around 30 at tickover. Revving the engine a little increased the pressure to 60 and the lamp extinguished. I have ordered a new sender, but is it common for the sender to go miles out of spec in this way? Frightened the life out of me.

mowogg
Minor Fan
Posts: 189
Joined: Mon Oct 22, 2007 9:45 pm
MMOC Member: No

Re: Oil pressure sender failure

Postby mowogg » Sat May 04, 2019 5:20 pm

I have had this occur to me too.

Online
Declan_Burns
Minor Legend
Posts: 1741
Joined: Wed Apr 18, 2007 7:32 am
MMOC Member: No

Re: Oil pressure sender failure

Postby Declan_Burns » Sat May 04, 2019 6:07 pm

I would recommend a pressure switch with a higher rating.
http://www.minispares.com/product/Class ... o%20search
Regards
Declan


Regards
Declan

mobylette
Minor Fan
Posts: 132
Joined: Sat Feb 13, 2010 5:02 pm
MMOC Member: Yes

Re: Oil pressure sender failure

Postby mobylette » Sat May 04, 2019 6:39 pm

Thanks Declan, that's a good idea, but I was just wondering how it could suddenly change spec. Having googled the switches likely design it seems probable that the diaphragm has failed/pinholed. New sensor now fitted and problem resolved.
Cheers
Martin


Who is online

Users browsing this forum: No registered users and 5 guests